jueves, 8 de mayo de 2014

OpenMandriva Lx 2014 and iBus, Success Still Eludes Me

The quest to make iBus work with OpenMandriva has been a difficult one.  I first tried to see if I had all the required dependencies according to this page:

    anthy
    GConf2 [*]
    ibus [>= 1.2.0]
    libanthydic.so.0()(64bit)
    libanthy.so.0()(64bit)
    libc.so.6()(64bit)
    libc.so.6(GLIBC_2.14)(64bit)
    libc.so.6(GLIBC_2.2.5)(64bit)
    libc.so.6(GLIBC_2.3.4)(64bit)
    libc.so.6(GLIBC_2.4)(64bit)
    libpython2.7.so.1.0()(64bit)
    python(abi) [== 2.7]

I discovered that I missed a couple.  Most of them are already installed.  However, even having all of them, iBus refused to launch. 

I followed the instructions on this page to activate iBus:

$ pkill -9 ibus
$ ps -ef | grep ibus
$ /usr/bin/ibus-daemon --xim &

The last command activated iBus, but it did not remember the IME selection (Japanese, Anthy).  

The page also said this, which I did not understand:

After ibus-daemon is invoked, Run ibus-setup to set the preference, enable input methods, also start ibus daemon.
e.g.
 $ ps -ef | grep ibus
foo 15735 15518  0 11:30 pts/3    00:00:17 /usr/bin/ibus-daemon --xim
foo 20037 15735  0 12:58 pts/3    00:00:00 /usr/libexec/ibus-gconf
foo 20039 15735  0 12:58 pts/3    00:00:06 python /usr/share/ibus/ui/gtk/main.py
foo 20041     1  0 12:58 pts/3    00:00:00 /usr/libexec/ibus-x11 --kill-daemon
foo 20042 15735  0 12:58 pts/3    00:00:01 python /usr/share/ibus-anthy/engine/main.py --ibus
 
So, that's as far as I have gotten now...
 

2 comentarios:

  1. new moondrake beta..
    http://folk.uio.no/peroka/moondrake/beta/

    ResponderEliminar
    Respuestas
    1. Hi, Per Øyvind Karlsen!

      Thanks, downloading right now! :)

      Eliminar